Novedades

Soporte y Recursos para Servidores Privados de WoW en Español

Únete ahora para obtener acceso a todo el foro. Una vez registrado y verificado tu email, podras crear temas, publicar respuestas,, dar reputación a usuarios, descargar, obtener soporte técnico y mucho más. Es rápido y totalmente gratis, ¿a qué estás esperando?

Pregunta

Haga preguntas y obtenga respuestas de nuestra comunidad

Responder

Responda preguntas y conviértase en un experto en su tema

Contacto

Contacta directamente con un administrador si presentas algún problema

Error en servidor auth

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
Al iniciar servidor auth aparece este error.

TrinityCore rev. 495d7d60d310+ 2020-09-22 03:06:06 +0300 (3.3.5 branch) (Win64, Release, Static) (authserver)
An error occurred converting string from UTF-8 to WStr ______


Alguna solucion? provoca crash
 
Última edición:

WoWCreador

Admin
VIP
Guardian
Capataz
Explorador
Desde
1 Oct 2019
Mensajes
805
Reacciones
355
Honor
102
En el archivo log del core sale más información sobre el error, la consola no muestra mucha información. Copia los errores que te salen en el log para tener mejor idea de que podra ser.
 

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
En el archivo log del core sale más información sobre el error, la consola no muestra mucha información. Copia los errores que te salen en el log para tener mejor idea de que podra ser.
Eso es el problema, el log aparienta normal, ni aparece ese texto... inicia normal, pero en el momento que alguien logea al server, crashea.
 

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
Tampoco creando Auth nuevo me soluciona esto, parece ser un error al montarlo...?¿?¿?
 

NapalMe

Capataz
Explorador
Desde
10 Oct 2020
Mensajes
34
Reacciones
25
Honor
47
Al iniciar servidor auth aparece este error.

TrinityCore rev. 495d7d60d310+ 2020-09-22 03:06:06 +0300 (3.3.5 branch) (Win64, Release, Static) (authserver)
An error occurred converting string from UTF-8 to WStr ______


Alguna solucion? provoca crash

¿Apareció el error antes o después de introducir o modificar alguna información en la base de datos?
Tiene pinta de que algún texto está en una codificación que no le gusta, quizás algún nombre de usuario, o el nombre del reino....
Personalmente configuraría toda la base de datos para que use solo la codificación UTF-8
Sin título.jpg
 

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
¿Apareció el error antes o después de introducir o modificar alguna información en la base de datos?
Tiene pinta de que algún texto está en una codificación que no le gusta, quizás algún nombre de usuario, o el nombre del reino....
Personalmente configuraría toda la base de datos para que use solo la codificación UTF-8
View attachment 1125
Este error esta desde que actualiza con los ultimos updates provenientes del repack de wow.creador

con el auth server de la version anterior no tengo ningun tipo de problema, parece ser un error de compilacion, ya que montando de nuevo con los archivos de SQL auth , ni actualizandolo , me quito este error.
 

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
Seria alguien descargar el ultimo repack , montarlo y ver si tiene el mismo error en consola, ya que en logs no sale este error, despues aparienta estar normal y funcionando el auth server, pero con el simple hecho de que alguien logea a su cuenta
crash inmediato
 

NapalMe

Capataz
Explorador
Desde
10 Oct 2020
Mensajes
34
Reacciones
25
Honor
47
Este error esta desde que actualiza con los ultimos updates provenientes del repack de wow.creador

con el auth server de la version anterior no tengo ningun tipo de problema, parece ser un error de compilacion, ya que montando de nuevo con los archivos de SQL auth , ni actualizandolo , me quito este error.
Por el mensaje de error, parece que quiere convertir texto en UTF-8 a otra codificación "WStr", así que yo buscaría que datos o herramienta esta usando dicha codificación, y la cambiaría/convertiría a UTF-8. Puede que sea la configuración de la base de datos, de alguna tabla, del servicio, o del cliente, vete a saber :)
Ánimo!

Edit: Eso de "WStr" parece que no es una codificación, si no un tipo de estructura de datos (estilo xml o algó así... no me ha quedado muy claro), y por lo que he leído parece que requiere que los datos estén en unicode (UTF), de manera que quizás el problema sea que los datos que intenta usar no estén en UTF-8. Yo revisaría la codificación de los nuevos datos.
 
Última edición:

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
Por el mensaje de error, parece que quiere convertir texto en UTF-8 a otra codificación "WStr", así que yo buscaría que datos o herramienta esta usando dicha codificación, y la cambiaría/convertiría a UTF-8. Puede que sea la configuracion de la base de datos, del servicio, o del cliente, vete a saber :)
Ánimo!
Gracias por tu ayuda pero ni putisima idea de que va esto, solo soy yo, montando y manteniendo el servidor, no puedo saber de todo, de mientras me quedare con mi auth server de la version anterior ya queme funciona de maravilla.

uno solo no puede hacer todo.
pero gracias
 

sabo

Guardian
Capataz
Explorador
Desde
20 Nov 2019
Mensajes
14
Reacciones
12
Honor
67
Yo aplicaria la clasica depurar el auth y ver la linea en donde crashea, o mirar bien en la config si hay mas opciones de debug para mirar a profundidad el error.
 

Aldoran

Capataz
Explorador
Desde
29 Jul 2020
Mensajes
81
Reacciones
73
Honor
57
Yo aplicaria la clasica depurar el auth y ver la linea en donde crashea, o mirar bien en la config si hay mas opciones de debug para mirar a profundidad el error.
Despues de pasar unos logs tambien veo que en consola de world tambien me sale ese error UTF-8...
Mas tarde intentare montar denuevo todo no veo que error he podido hacer...
 
shape1
shape2
shape3
shape4
shape7
shape8
Top